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General Overview 

 
Introduction This class includes explanations and activities designed to teach 

important report topics.  Please feel free to ask questions at any time. 

 
Goals The following are the goals for today: 

• To understand the different types of reports provided by IFAS 
• To navigate through IFAS reports 
• To describe how to export a CDD report to Excel 
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Reports 

 
Introduction IFAS includes two types of reports: 

• CDD (Click, Drag and Drill) 
• Standard Reports 

 
Objectives  The following objectives are covered in this section: 

• Open and run a CDD report. 
• Describe the procedure for exporting a CDD report to Excel. 
• Describe Standard Reports and how to run them. 
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CDD Reports 

 
Introduction CDD reports are named for the Click, Drag, and Drill features.  To access these 

reports, either click the blue Runnning Man icon  on the toolbar or choose 
CDD reports at the end of the Menu Tree. A listing of reports will appear from 
which you select.  Click the plus (+) sign in front of the title to open the exact 
report you want. 
 
Some reports have more than one version, with different information, prompts, 
and selection criteria. 

 



6 
 

CDD Reports continued 

 
Initial Setup Before launching a report, it is necessary to set the Report tab in the Options 

menu.  Follow this procedure once to set up reports. 
 

Step Action 
1 Click Edit > Options in the menu bar.  The following Options 

box displays. 

2 Click the Report tab. 
3 In the General section of the Report tab, type 99 in the Fetches 

per Cycle space.  This allows the report to run faster. 
4 Change the Pages in Memory setting to 99, the maximum.   

Note:  The default for Pages in Memory is 30.  This means that 
you are seeing only 30 pages of the report at a time.  If you skip to 
the end of the report, you will see only the last 30 pages, causing 
you to lose the pages at the beginning.  The number of pages in 
memory is the number of pages you see on screen.  If you have 
lost pages, re-run the report. 
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CDD Reports continued 

 
Viewing 
Report Titles 

If you want to change the way the reports are listed, right click in any white area 
of the listing.  This popup box displays.  Reports are shown with name only, as 
depicted below. 

 
 

Continued on next page 

Right click 
anywhere in 
the white 
space to 
change the 
display. 
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CDD Reports, Continued 

 
Viewing Report 
Titles 
(continued) 

To display reports by name and description, click Show Name and 
Description in the popup box, as depicted below.   
 

 
 
Note:  The screen above lists names and descriptions for each Budget report.  
This is the recommended listing.  If the user needs to contact the ITC Help 
Desk about a CDD report, they will be asked to provide the name of the 
report.  It should be given with the name and description. 
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Running the CDD Report 

 
How to select a 
report 

From the listing in the CDD report tree, you can choose a report by double-
clicking the title of the report.  In some cases, you will find variations of the 
report listed when the title is expanded.  To expand the report, click the plus 
(+) sign that appears before the title.  The plus (+) sign changes to a minus (-) 
sign.  Choose the variation desired by double-clicking it.  See the example 
below. 
 

 
 

The variations of BD_FORM_3441 are ADDITION and 
CHANGE_DELETE.  You would choose the variation desired.  If, however, 
you double-click the title, you would bring up the first listed variation.  In this 
case, ADDITION would be selected by double-clicking BD_FORM_3441. 

 
Selection 
Criteria 

After choosing the report, a selection criteria box displays.  Here is where you 
limit your search for data.  The selection criteria box for the above 
ADDITION report for BD_FORM_3441 follows: 
 

 
 

For this search, only fiscal year 2012 is included.  The Reference field is for a 
number assigned to the record by the system. 
 
Note:  The wildcard symbol (*) in the reference field would include all 
reference numbers in the search results. 

Continued on next page 
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Running the CDD Report, continued 

 
Viewing on 
screen practice 

After completing the selection criteria box, the report data displays on screen.  
Follow this example: 

Step Action 
1 a.  Select the CDD report selection from the menu tree by clicking 

the plus sign.  Click Subsystem Folders by clicking the plus sign. 
 
b.  Click Budgeting by clicking the plus sign. 
 
c.  Select BD_FORM_400 by double-clicking.  Be sure to use the 
correct department code. 
 

 
 

Note:  This report does not have variations.  When there are 
variations and you double click the form name, you will get the 
first variation listed. 

2 Complete the selection criteria box. 
 

 
Above, all departments and divisions are included with use of the 
wildcard symbol.  The ledger must be entered.  The fiscal year is 
2012.  
 
Note:  Remember, the ledger must be in capital letters. 

3 Press Enter or click OK. 
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Running the CDD Report, continued 

 
  

Step Action 
4 This is an example of a report produced by double-clicking 

BD_FORM_400. 
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Running the CDD Report continued 

 
Drill within the 
report 

“Drill” is a means of displaying additional reports related to the selected data 
in the column.  To do this, with your cursor, hover over an entry.  When the 
cursor changes into an icon of a drill (or magnifying glass), double-click and 
the related report displays.   

 

 
 
 

 
 

Continued on next page 

Resulting 
report from 
the drill 
down 
operation 
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Running the CDD Report continued 

 
Drill within the 
report 
(continued) 

In addition, there may be an image attached to a report.  Hovering over this 
field displays a camera icon.  Click the item to see the image. 
 

 
 
Note:  Not all reports will have related reports or images. 
 
When drilling, you may get a message that says the item is archived.  In that 
case, e-mail the Help Desk at ITCHelpDesk@hctx.net to get help on accessing 
the information. 
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Printing CDD Reports  

 
Printing CDD 
Reports 

Follow these procedures for printing CDD reports. 
 

Step Action 
1 Select and run the CDD report. 
2 Click File > Print.  Or, click the printer icon  

3 The Print dialog box for your default department network printer 
displays.  Set the printing range and number of copies. 

4 Click OK. 

 
Your output goes to the specified printer. 
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Exporting CDD Reports to Excel 
Introduction Before you start this export process, run the report on screen in IFAS to be sure 

that you have selected the desired data. 

 
Exporting 
to .txt file  

Follow this procedure to export a CDD report to Excel. 
 

 Action 
1 Click the Running Man  on the toolbar. 
2 The Open and Run dialog box opens. 
3 Choose a report by highlighting it.  Click the down arrow of the To Screen 

button.  Choose File in the drop-down box. 
 

 
Note:  This option is only available for selection after pressing the  
Running Man and then highlighting the report. 

 

Continued on next page 

 



16 
 

Exporting CDD Reports to Excel, Continued 

 
Exporting to 
.txt file 
(continued) 

 
4 Double-click the report you want to run.  The selection criteria dialog 

box for the search appears.  Complete the fields as needed.  Click 
OK.  The report will be converted to a text file for transfer to Excel. 
 

5 The Export to File dialog box appears. 
 

 
 

6 Accept the default Export Type as Tab.   
  

Continued on next page 
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Exporting CDD Reports to Excel, Continued 

 
Exporting to 
.txt file 
(continued) 

 
Step Action 

7 Click the Browse button to specify the location and create a 
file name.   
 

 
 

8 Click Save.  This file will be in the .txt format.   
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Exporting CDD Reports to Excel, Continued 

 
Exporting to 
.txt file 
(continued)  

 
Step Action 

9 All Regions to be Exported are included as a default.  
Choose the region that you want to exclude from the report 
on the Export to File dialog box.  Clicking on the 
checkbox will uncheck the item and exclude it from the 
export.  Uncheck Page Header and Page Footer. 
 

 
10 Click OK to save as a .txt file.   

 
You will now use the standard steps for importing 
documents into Excel. 
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Exporting CDD Reports to Excel, Continued 

 
Excel 
procedures:  
importing .txt 
files 

The following are general procedures used for importing a text file 
into Excel. 
 

Step Action 
1 Open Excel.  Click Open in the Office Button.  Change the 

Files of Type to Text Files.  Use the Look in field to find 
the location where you saved the CDD text document. 

 
2 Select the name of the file created from the CDD report. 
3 Click Open. 
4 The Text Import Wizard opens.  Be sure that Delimited is 

selected.  Click Next for step 2 of 3. 
 

Continued on next page 
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Exporting CDD Reports to Excel, Continued 

 
Excel 
procedures: 
importing .txt 
files 

 
5 Select the desired delimiter and click Next for step 3 of 3. 

 

 
6 Select the Column data format for each column.  Then, 

click Finish. 
 

 
 

Continued on next page 
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Exporting CDD Reports to Excel, Continued 

 
Formatting the 
Excel report 

With the CDD report in Excel, you can resize any column or cell to 
accommodate data.    
 
Note:  Excel will default to the portrait orientation.  Switch to landscape 
for easier reading.   
 
To get the best hard copy of your report, follow these steps. 
Step Action 

1 Click the Print Preview on the Office button under Print. This 
gives a view of what the document will look like after printing. 

2 Click the Page Setup icon.  Change the orientation from 
Portrait by choosing Landscape. 
 

3 Under the Page tab, Scaling allows you to format the columns.   
4 You may also make margins as desired by clicking the Margins 

tab. 
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JustIFAS and CDD Reports 

 
Introduction This is information related to the website dedicated to IFAS. 

 
JustIFAS www.justifas.net is a web site dedicated to IFAS assistance.  On the right of 

the screen, you will find help on topics related to CDD reports.  CDD4U lists 
and describes selected CDD reports and outlines how to run these reports.  In 
addition, it provides instruction on how to e-mail them to co-workers.  CDD 
Reports links to a listing of all reports and provides additional information.   
 
On the left of the screen, CDD reports are filtered by module. 

 
 

 

Topics leading 
to CDD 
reports for the 
modules 
specified 

Link 
leading to 
all CDD 
reports 
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Standard Reports 

 
Introduction Standard reports are found within each module; they are non-CDD reports.  

Navigate to these Standard reports by choosing the desired module in the 
Menu tree.  The reports are listed within the module and some reports have 
more than one version, with different information, prompts and selection 
criteria. 
 
Note:  Harris County generally uses CDD reports rather than the Standard 
reports covered here. 
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Standard Reports continued 

 
Initial setup These procedures are for confirming that your computer will print to the IFAS 

printer in your area.  Standard reports use only the IFAS printer. 
Step Action 

1 Click Edit>Options on the menu bar.  The Options dialog box 
displays. 

2 Under the Host Printers tab, select the name of the printer that is 
designated as the IFAS printer.  The default printer name should 
always end with C.  This will allow the report to print according 
to how it was written; ie., landscape or portrait.  Keep the priority 
setting of 8. 

3 Click OK. 
Note:  You will do this only once, unless you want to change the 
printer you are going to use. 

 

Continued on next page 
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Running the Standard Report 

 
How to select a 
report 

There are numerous standard reports from which to choose.  In some 
cases, you will find variations of the report listed when the title is 
expanded.  To expand a report, click the plus (+) sign that appears before 
the title.  The plus (+) sign changes to a minus (-) sign.  Choose the 
variation desired by double-clicking it.   
 
Note:  You may not have access to all reports depending on your security. 
 

 

 
 As an example, observe CSDRDC:  DTE Doctor’s Certificate Rpt.  The 

Menu tree below shows an expanded DR:Department Reports.  We highlight 
the DTE Doctor’s Certificate Report. 
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Running the Standard Report continued 

 
Selection 
Criteria 

After double-clicking DC: DTE Doctor’s Certificate Rpt, the following 
selection criteria box displays.  Completing this selection criteria box yields 
the report.   
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Running the Standard Report, Continued 

 
Standard 
Report Buttons 

On the toolbar of the selection criteria prompt box, find these buttons: 
 

• Checkmark  - This starts the record search. 
• The red X  - This closes the dialog box for the selection criteria. 
• The checkbox for running in the background  - This 

should always be checked. 

The Special Button  lists defaults and usually should not be 
changed.  You should check with your supervisor to determine if you are 
going to print special forms and which printer you should use. 

 
How to run a 
Standard 
report 

This section gives you basic information for running Standard reports.   
From the listing of reports, choose the desired report by double-clicking on its 
title.   
Note:  In some cases, you will find variations of the report listed when the 
title is expanded.  To expand the report, click the plus (+) sign that appears 
before the title.  The Plus (+) sign changes to a minus (-) sign.  Choose the 
variation by double-clicking it. 

Continued on next page 
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Running the Standard Report, Continued 

 
How to run a 
Standard 
report 
(continued) 

 
Step Action 

1 Select CS:Client Specific by clicking the plus(+) sign. 
2 Click DR:Department Reports by clicking the plus (+) sign. 

 
Note:  You may use @ as a wildcard to specify all of the records in a 
field. 
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Running the Standard Report, Continued 

 
How to run a 
Standard 
report 
(continued) 

Step Action 
3 Double-click DC:DTE Doctor’s Certificate Rpt.  The following 

prompt box displays. 

4 Complete the selection criteria and check that the printer is the 
IFAS printer in your area. 
 
Note:  You need to see all criteria.  Do this by right clicking in 
the gray area. This will allow you to see if there are more options 
available; choose ‘Show All.’ This is something done in addition 
to using the scroll bar to find fields that aren’t visible on the 
initial view. 

  

 
 

You may use 
a wildcard in 
a field 
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Running a Standard Report, Continued 

 
Selection 
Criteria 
Examples 

The figure below shows an example of criteria that you can choose for 
a selected standard report.  Note that you have radio buttons as well as 
checkboxes.  You can choose only one radio button.  You may choose 
several checkboxes that pertain to your search.  Be sure to use the 
scroll bar to find and complete fields that may not be visible on the 
initial view.  The more criteria, the more exact and concise the 
resulting report will be.  This should make the print job run faster.  
When you complete selection criteria, right click in the gray area.  
This will allow them to see if there a more options.  Choose “Show 
All.” 
 
See the screen shot below for examples of selection criteria.  Make 
appropriate selections for your criteria. 
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Printing Standard Reports 

 
Printing 
Standard 
reports 

To print a Standard report, follow these steps. 
Step Action 

1 Double-click the report from the Insight Explorer view. 
2 An Insight dialog box displays.  Complete the selection criteria.   
 

 
3 Click the green checkmark to begin printing. 

 

Green 
Checkmark 

Selection 
Criteria 

Printer settings  
(Don’t change.) 
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Printing Standard Reports, Continued 
 

 
Standard 
Report 
Example 

This is an example of a standard report. 
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Printing Standard Reports, Continued 

 
Output View  

Step Action 
1 Check the Output view  icon in the toolbar for information 

about the job. 

 
This screen documents if there were errors for the print job or if 
the job was successful. 

  

Output 
View 
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Review 
 
True or False 
 
1.  To change the way the name of a CDD report is displayed, left click the white area anywhere 
on the screen. 
 
2.  You may have to scroll down to see all fields for a Standard report dialog box. 
 
3.  To find the IFAS printer that print jobs for Standard reports, go to Edit>Options> Host 
Printers. 
 
4.  When exporting a CDD report to Excel, Delimited is the file type selected to describe your 
data. 
 
 
Short Answer 
 
1.  Explain why it is important to check checkboxes and fill in fields when preparing a report. 
 
 
2.  What are the steps for printing a CDD report? 
 
 
3.  You may not have access to all reports.  Why? 
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Review Answers 
 
True and False 
 
1.  False – right click the white area in the dialog box. 
 
2.  True 
 
3.  True 
 
4.  True 
 
 
 
 
Short answer 
 
1.  Check checkboxes and fill in fields so that the report meets your needs and is as concise as 
possible and it may run faster. 
 
 
2.  To print a CDD report: 
 

• Display the report on screen. 
• Click File > Print or click the printer icon in the toolbar. 
• Set the printing range and number of copies. 
• Click OK. 

 
 

3.  You may not have access to all reports because you lack the proper security. 


